Subject: Re: Megahertz XJEM3336 Ethernet/Modem PCMCIA Card on a PowerBook 2400
To: None <,>
From: Ben Harris <>
List: port-macppc
Date: 09/20/2000 00:17:59
[ I can't help with your actual problem, but I can chase you away from some
  of the wrong trees. ]

In article <p04310101b5ebcc94f2f1@[]> you write:
>     mhzc0 at pcmcia function 0: Megahertz X-JACK Ethernet Modem
>     mhzc0: unable to allocate space for Ethernet portion
>So I thought, maybe the rest of the system is out of date now that 
>I've compiled a new kernel.

Given that the problem occurred before anything other then the kernel (and
the boot blocks) had run, this is unlikely.

>I think it's not working because the devices associated with this 
>card aren't in /dev.  Shouldn't there be pcmcia, mhzc, and sm devices 
>listed in /dev?

No.  Network devices in BSD systems are famous for not having device nodes. 
Devices which don't export a user interface (like the pcmcia drivers) also
don't need device nodes.

In any case, your problem occurred before the root filesystem had been
mounted, so its contents shouldn't have affected what was going on.

I suspect your actual problem is that no-one has tried to use the mhzc
driver on a macppc system before, and that there's some subtle interaction
between the two that needs to be worked out.

Ben Harris                                                   <>
Portmaster, NetBSD/arm26               <URL:>