Subject: Re: Blue and White G3 Install
To: Chris <>
From: Laurent de Segur <>
List: port-macppc
Date: 06/24/2000 13:31:43
I ran into the same problem. I got a zip drive on my machine so I tried
suntaring the boot.fs to the zip disk (overriding sector 0) then in OF
typing "boot zip:0". No luck. Then I got the ofwboot.elf on a HFS formatted
disk and typed (still in OF) "boot zip:,ofwboot.elf". This time the thing
loads but is missing the netbsd file. So because the Yosemite boots ELF
files anyway, I just copied the netbsd-GENERIC (unziped of course) onto the
zip disk then (still in OF, lots of reboots these days) typed
"boot zip:,netbsd". I had some problem with load-base. So I set it up to
0x6C000000 (not sure of this address, check the load-address in the ppc-faq)
by typing (you know where) setenv load-addr 6c000000 and then boot

The file loaded (I had to retry a few times because of the caught failed
err.) I got to the point where I could see lots of data dumped to the screen
and then it stopped. Here are the info I already sent in a previous message.

...lots of info removed, then...

md0: internal 1600K image area
boot device: <unknown>
root on md0a dumps on md0b

Then it hangs here :-(
It apparently couldn't find the fs root. I made a cd image after the .iso
file on the ftp site and the CD was in the drive. I was hoping that the boot
process on the zip would go and mount the cd. Nope!
So I guess I need more than netbsd kernel on the zip. I haven't had to much
time to look further. The read-me jumps from the stage at where you make an
image to the sysinst, so that doesn't help a lot. I guess that if you don't
have a zip and no network, you may have to burn a cd with kernel in the root
level and type: "boot cd:,netbsd". Now the netbsd.iso image contains all the
pieces for all archs, so you need to move the things you need for your
platform at the right place.

That is pretty much all I can tell you about NetBSD on my B&W right now. If
you find anything let me know and I will be glad to continue the


----- Original Message -----
From: "Chris" <>
To: "NetBSD Mailing List" <>
Sent: Saturday, June 24, 2000 12:38 AM
Subject: FW: Blue and White G3 Install

> ----------
> From: Louis Guillaume <>
> Newsgroups: comp.unix.bsd.netbsd.misc
> Date: Fri, 23 Jun 2000 19:23:48 -0400
> Subject: Blue and White G3 Install
> Hi All,
> I have read the docs regarding NetBSD/macppc but it appears there is a
> critical piece missing.
> The instructions describe copying some files including one called boot.fs,
> which I imagine is the 'boot filesystem', which would contain a small
> and an installer program.
> Without a floppy drive, how does one get the machine to uncompress and
> that filesystem then run the installer?
> I tried copying the items onto a Zip disk, but the machine won't boot from
> it. In Open Firmware I tried...
> > boot zip:0
> ... to no avail.
> I tried selecting the Zip drive in the Startup Disk control panel (kinda
> knew this wouldn't work!)
> Even if I had a cdrom with all these items on it, how do you get that
> initial kernel and installer to run?
> This is the piece missing from the instructions. They tell where to get
> packages and the installation files and then what do do once you are in
> installer (and a bunch of stuff about Net Booting in between, which is
> really cool! but not an option for me.)
> Any help would be greatly welcome.
> Louis