Subject: Re: Netbooting an iMac...
To: None <>
From: Mason Loring Bliss <>
List: port-macppc
Date: 05/20/2000 15:16:48
I'm guessing that this might be indicative of the problem, but I'm
not sure. Acheron is the i386 server. Philemon is the iMac that's
trying to boot off of the i386.

15:09:20.214279 philemon.49206 > acheron.tftp:  24 RRQ "/tftpboot/imac"
15:09:20.227949 acheron.63070 > philemon.49206:  udp 19
15:09:20.228278 philemon.49206 > acheron.63070:  udp 20
15:09:20.228404 acheron > philemon: icmp: acheron udp port 63070 unreachable
15:09:25.215809 philemon.49206 > acheron.tftp:  24 RRQ "/tftpboot/imac"
15:09:25.229428 acheron.63068 > philemon.49206:  udp 19
15:09:25.229756 philemon.49206 > acheron.63068:  udp 20
15:09:25.229878 acheron > philemon: icmp: acheron udp port 63068 unreachable

If anyone has any ideas, I'd enjoy hearing them. I'm not yet particularly
familiar with the protocols. Thanks in advance for suggestions or pointers!

On Fri, May 19, 2000 at 01:31:16PM -0400, Mason Loring Bliss wrote:

> Hi, all.
> I'm trying to boot an oldish iMac with the latest -current snapshot. I'm
> encoutering several weirdnesses. The host system is i386 with a kernel
> built a few days ago and userland built on the 7th of this month.
> I successfully netboot a SPARC IPC from this box, so I'm pretty sure
> that tftpd is working properly. Notes:
> * The imac eventually gives me a timeout message after failing to fetch
> the kernel. (I tried having it fetch ofwboot.elf with the same results.)
> On returning, it complains of the file being too small (zero bytes, I
> believe).
> * When I tried having dhcpd catch the boot request, the iMac seemed not
> to accept what it was fed - it would get a response and then just ask
> again.
> * The iMac is getting the correct address and boot file information from
> bootpd, and is even pingable after getting the information, but it fails
> to grab the kernel from tftpd.
> * tftpd is able to send the proper file elsewhere, so it's not any sort
> of permissions problem.
> I'll see about staring at the packets that go back and forth to see if
> I can determine what's happening. If this is a no-brainer, though, feel
> free to chime in. :)
> Here's my bootptab entry, mildly chopped:
>     :ip=
> I've also tried this without hd, with bf=/tftpboot/ofwboot.elf instead.
> Thanks in advance for clues.
> -- 
> Mason Loring Bliss             (( "In the drowsy dark cave of the mind dreams
>  )) build  their nest  with fragments  dropped
> ((  from day's caravan." - Rabindranath Tagore

    Mason Loring Bliss  I m m a n e n t i z e
awake ? sleep : dream;  t h e E s c h a t o n