Subject: Re: NetBSD 2.0 thanks, and disappointment
To: None <>
From: Donald Lee <>
List: port-mac68k
Date: 04/20/2005 21:45:51
>On Sun, Apr 17, 2005 at 12:28:33PM -0500, Donald Lee wrote:
>> I ran into three killer problems, though.
>> 1. rsh was unreliable.  There are a few of my scripts that do rsh operations
>> to other machines, and when I ran these scripts, the rsh would
>> hang (for days, not minutes or hours)  This was unpredictable, but
>> very repeatable.  (The "other machine" in this case is running NetBSD 1.6.2)
>That's very strange. I'd suggest posting on tech-net about this. Is DNS 
>set up right (thoguh that shouldn't hang for days...)?

It didn't behave like a DNS problem.  I had shell scripts that did series
of rsh operations on the "main" box, and about 1 in 4 would not finish.
It seemed to vary which one, too, and didn't seem to matter what the
load on (either) machine was.

I could post to tech-net, but I don't have the machine set up anymore.
If I do anything, I'm inclined to try again with 2.0.2.

>> 2. Performance of wget was awful.  Under NetBSD 1.3.3, a wget of a trivial
>> URL would use .3 user .2 sys.  Under NetBSD 2.0, this was 4.2u and 2.5s.
>> I did some ktrace work and as far as I can tell, this is because NetBSD
>> 2.0 uses nls (multi-language stuff), and does a bunch of unnecessary work.
>> I tried to turn off NLS in the wget build, but was unsuccessful.
>> (I think the wget Makefile is busted in this regard)  Note that I could
>> not run the 1.3.3-built wget on NetBSD 2.0 due to some dynamic
>> library missing problem that I did not chase down.
>Oh, 1.3 was a.out. You will need to set up a lot of COMPAT_13, COMPAT_14, 
>etc. in your kernel and also the a.out shared library support. I don't 
>still have any a.out systems running, so I'm not 100% sure how to do this.
>The emulators/compat13 package may also be needed, however I'm not sure if 
>it builds its libraries a.out... Ripping the libraries off of the 1.3.3 
>system certainly would work.

What I ended up doing is re-building under 2.0.  This worked, but
performed poorly.  Are you suggesting that I *should* run a.out
on a 2.0 system?