Subject: Quadra 605 SCSI issues
To: None <>
From: John Klos <>
List: port-mac68k
Date: 06/29/2004 19:32:58

Somewhere between NetBSD 1.6 and current-then, 2.0 now, certain SCSI 
related code changed which affects Quadra 605 type machines. When I was 
running current from several months ago, I remember the system drive would 
come up in the dmesg as offline. That's been fixed, but both then and now 
I cannot use the disk extensively without the system locking up.

I have a number of Quadra 605 machines (I like that they are so small), 
and ones which were completely stable for months at a time under 1.6 now 
crash within a day or so of heavy use. So I suspect that some SCSI related 
change has made things worse.

My Quadra 700 and Quadra 650/800 machines are all completely stable with 
1.6.2 and 2.0, compiling things for days at a time, so this appears to be 
specific to Quadra 605s.

Also, slightly relatedly, does anyone know which Quadra models support 
syncronous mode and which do not? My Q700 comes up in sync mode:

sd0: sync (160.0ns offset 15), 8-bit (6.250MB/s) transfers, tagged queueing

But my 650/800 does not:

sd0: async, 8-bit transfers, tagged queueing

Anyone know which models do what?

John Klos
"I accept the legal conclusion of the Attorney General and the Department 
of Justice that I have the authority to suspend Geneva (conventions) as 
between the United States and Afghanistan," Bush wrote in a secret order. 
"I reserve the right to exercise this authority in this or future