Subject: Re: ISO image of NetBSD 2.0_BETA/mac68k (2004-06-12)
To: Daniel Bolgheroni <>
From: Frederick Bruckman <>
List: port-mac68k
Date: 06/21/2004 23:05:42
On Mon, 21 Jun 2004, Daniel Bolgheroni wrote:

> On Mon, 21 Jun 2004 18:37:17 -0500 (CDT)
> Frederick Bruckman <> wrote:
> > No? I did a little experimenting, and found that the old Apple 300i
> > can read Memorex 48X CD-R media (burned at 24X for good measure), but
> > not TDK CD-RW. I burned another image with "--macbin", too, so that
> > the Booter program on the CD can be executed directly. This installed
> > fine, and appears to be fine.
> Why don't you try to burn the image at a lower speed? It works for me,
> whatever the media.

Does that really help? I thought I tried one at 24X before, and it
more or less worked, but it errored out when reading the sets. (This
time, it gave a couple of esp0 timeouts, but pushed throught it.) The
CD-RW's already burn at 4X, tops. The Finder doesn't even see those.

> > The updated image may now be found at the same URL:
> >
> >
> What's the correct MD5 checksum?

 MD5 (mac68kcd.iso) = 4ed2b2cac68302950660703f19a86220

And now I've put an MD5 file in the same directory, since you asked
for it. ;-)

> A problem I had sometime ago was: what's the correct parameters to use
> with mkisofs to create a mac68k ISO image?

As I wrote in the README in the same directory, I used:

 mkisofs -R -hfs -probe --macbin -o mac68kcd.iso .

...assuming you're in the directory that contains "mac68k". With that,
there's a "mac68k" at the root of the CD-ROM, and the default path for
the "cdrom" option is correct.

This would be slightly better:

 mkisofs -r -hfs -probe --macbin -o mac68kcd.iso .

(The "-r" just fixes the owner and permissions.) The "-R" or "-r"
makes an ISO file system for NetBSD (and others); the "-hfs" makes it
look like an "HFS" volume to Mac OS. The "--macbin" is really cool --
it makes the MacBinary files double-clickable in the Finder.

Actually, I think the "-probe" thing doesn't really work, as the HTML
and text files in "mac68k" have no icon. I should create a file to use
with "-map" for them.

> Last time I burned an image, I was able to read correctly on i386
> (NetBSD) but with strange names in mac68k (Mac OS) machines.

I couldn't believe we don't have scripts for this in the tree already,
but we don't seem to.