Subject: Re: Q840AV doesn't like 1.5 Alpha2
To: Frederick Bruckman <>
From: Jesse Reynolds <>
List: port-mac68k
Date: 09/18/2000 23:31:49
At 06:43 -0500 18/9/00, Frederick Bruckman wrote:
>On Mon, 18 Sep 2000, Jesse Reynolds wrote:
>>  I tried installing NetBSD 1.5 Alpha2 snapshot of 5 Sept and it
>>  doesn't seem to work. The kernel panics and bombs out to the debugger
>>  shortly after recognising the keyboard and mouse, exerpts as follows:
>It looks like it's failing in the place the video probe should be.
>What video mode do you boot in? Maybe see if changing the video mode
>causes the symptom to change. Do all the modes work under Mac OS? If
>you have bad video memory, it'll be obvious at the larger resolutions.

Well I haven't tried all video modes, but I have tried 832x? at 
millions of colours, and 640x480 at 1bit black and white, makes no 
difference. All video modes work fine in Mac land - and indeed NetBSD 
1.4.2 worked fine in both these video modes.

Something I neglected to mention though, is that when 1.5a is loading 
in millions of colours, the text isn't clear white on black as per 
1.4.2, but instead is compressed horizontally and is blurry red and 
blue on black. However when 1.5a is loading in 640x480 b&w it looks 
clear etc, just like 1.4.2 in this mode.

>Also, the "ams" device is somewhat uncommon -- you could rule out that
>driver by booting without the mouse, or with a different mouse.

I've tried booting without the mouse and no luck there, but haven't 
tried another mouse. I'll give it a go. I'll try a different keyboard 
too perhaps. Okay I just tried with an old squareish Apple Bus Mouse 
and the same thing happens.

>  >
>>  aed0 at adb0 addr 0: ADB Event device
>>  akbd0 at abd0 addr 2: extended keyboard
>>  wskbd0 at akbd0: console keyboard, using wsdisplay0
>>  ams0 at adb0 addr 3: Logitech MouseMan (non-EMP) mouse
>>  wsmouse0 at ams0
>>  Kernel Illegal Instruction trap.
>>  trap type 2, code = 0x0, v = 0x0
>>  kernel program counter = 0xdea4c
>>  kernel: Illegal instruction trap
>>  pid = 0, pc = 000DEA4C, ps = 2400, sfc = 1, dfc = 1
>>  Registers:
>>  <blah blah>
>>  Kernel stack (00277ECC):
>>  <blah blah>
>The names of the subroutines in the stack trace ('t') could be useful.

The debugger is new to me, so please bear with me. When I type 't' or 
'trace' in the dubugger I get such subroutine names as "domaininit", 
"uvm_fault"... mean anything?

>  > Specs: Quadra 840AV, 80Mb Ram, 1Gb SCSI disk, MacOS 8.1 on 200Mb
>>  partition, AsanteFAST 10/100 nubus ethernet card.


       Jesse Reynolds - Virtual Artists Pty Ltd -
             Email: jesse (at)        - http://virtual.artists