Subject: Re: Compiling getdate
To: Josh Hope <>
From: Paul Goyette <>
List: port-mac68k
Date: 08/07/1997 04:21:56
On Thu, 7 Aug 1997, Josh Hope wrote:

> I found this little Linux program on sunsite. I grabbed the source and
> tried to compile it. It gets the time from a NTP server and sets the clock
> to that time. Since I'm using NetBSD, this is pretty necessary ;) In 5
> hours, my clock went off by 10 minutes. In 3 days, it was off by 1 hour.

Is that all?  When I do my nightly backups to my Exabyte-8200 (running in
polled-I/O mode 'cuz PDMA doesn't work), my clock loses an hour in an
hour!  Yes, really, my clock runs at half speed!  :)

> Anyways, I *do* have xntpd. It's set up correctly, but it doesn't change
> the setting of my clock! The /etc/ntp.drift file does record correct
> drift, but it does nothing my clock...

Hmmm.  ntpd resets the clock just fine for me.

> Anyways, I grabbed this simple and small program, and tried compilin
> git...I get the following error:
> []% make
> cc -O2 -DHAVE_ADJTIME   -o getdate getdate.c
> /var/tmp/cc0251321.o: Undefined symbol `_stime' referenced from text
> segment
> *** Error code 1
> Stop.
> That's real similar to the error I get when trying to compile something
> that needs -lcrypt at the end of the command line. Except, it's
> `_scrypt'...
> So, is this going to be impossible? Or can I get it working under NetBSD?
> :)

Maybe you need to add ``-lntp'' ??  Just guessing, but there _is_ a

> Thanks a lot for any help!
> Josh

| Paul Goyette       | PGP Public Key fingerprint:  | E-mail addresses:     |
| Network Consultant |     0E 40 D2 FC 2A 13 74 A0  |    |
| and kernel hacker  |     E4 69 D5 BE 65 E4 56 C6  | |