Subject: A ppp problem solved and another problem found
To: None <port-mac68k@NetBSD.ORG>
From: Jon Lefman <>
List: port-mac68k
Date: 04/04/1997 02:22:15

Remember how I was always disconnecting when using sup?  Well, I think I
solved a part of the problem.  I changed the stty line in my ppp-connect
script used in ppp-up.  It used to say "stty clocal".  I changed it to
"stty -clocal".  It seemed to work.  Reading through the man page for stty,
clocal says that I'm not using modem control.  That seemed to be incorrect.
I changed it and I was able to stay connected for hours.  Is this a
theoretically good thing?

Now the next problem, why won't ppp stop sending as soon as my modem's flow
control light goes low?  It works just fine in MacOS, but it doesn't
respond in NetBSD.  Not sure why....any hints?  I'm assuming it's an stty
setting that I'm not using.  I am currently using stty -clocal crtscts

I noticed a problem or two in the ppp scripts in /private/wrstuden on  First, the README file has a .tgz filename.  It's a
regular text file.  Just pointing it out.

Another possible problem is that the options file doesn't appear to be used
unless pppd uses a file called options.  If it does look for that file,
please disregard the rest of this.  If it doesn't, the options file never
gets read in.  The script file ppp-up says something like: pppd 19200
connect "insert script names here".  If an extra options file is going to
be used, pppd needs to have something like this: pppd 19200 file
options_file_name connect "insert script names here".  I couldn't find
anywhere else where the options file was used.  This could possibly be
misleading if trying to configure pppd.

Thanks for the help,