Subject: Major problems with NetBSD on LCIII...HELP!
To: None <port-mac68k@NetBSD.ORG>
From: John Albers-Mead <John.Albers-Mead@InternetOne.COM>
List: port-mac68k
Date: 12/31/1996 10:17:51
My system configuration:
LC III (68030 w/ FPU)  12 MB RAM
SCSI 0: 750 MB Quantum Lightning (internal)
        Partitioned into 350MB Mac - 24MB Swap - Rest ROOT
        (I think I read that there may be a problem here)
SCSI 2: 44MB Syquest (all Mac)

  NetBSD 1.2
  Instaler 1.1
  Booter 1.9.4 (allocated 5MB RAM)

I have had NetBSD up and running with a few problems for a little while
using GENERIC-9 and the full installation.  Every once in a while, it would
hang for a few seconds and the speaker would start making a very high
pitched rythmic tone (sort of a weee...weeee...weee..weee kind of thing).
Most of the time this would come back with some sort of error and I would
be on my way again with things seemingly running fine.

Last night I had the same thing happen with the tone but it lasted quite a
while longer and then kept repeating this error message:

sd0(sbc0:0:0): non-media hardware failure, data =6d b6 db 6d b6 db 6d b6 db 6d

followed sometimes by something like "last message repeated 13 times" and
would not respond to any commands that I tried.  I could not do a shutdown
or reboot so did the manual flipping of the switch to restart and got the
missing disk icon at startup.  I heard the internal drive spin up when I
powered on but after a few seconds it spun down.  I could not get it to
boot and had to start off the Syquest.  I tried to mount the internal drive
from the Syquest using Charismac's Anubus Utility and APS Power Tools and
the only option that I had was to initialize the whole drive but
initialization failed each time.

I restarted from the syquest and held down the apple-option key combo to
rebuild the desktop and the internal hard drive showed up again.  I tried
to boot into netbsd and everything seemed to be working fine until I
clicked "cancel" to boot it up.  I got a major cursor freezing crash.  I
tried to restart many times and it would freeze at the same spot each time.

I decided to reformat the root partition with mkfs and install everything
again (grrr...).  This worked without returning any errors.  I then
installed everything over again from the current version and put on
GENERIC-15 which I have been told works well with the LCIII.  This
installed overnight and this morning I went to restart and -YEA!- the whole
thing locked again!

At least the drive shows up...


                                                  John Albers-Mead
                                             WWW/Graphic Developer
                                                   THINK New Ideas
                                                1113 Spruce Street
                                           Boulder, Colorado 80302