Subject: Re: What is getty?
To: Paul Goyette <>
From: Jonathan Short <>
List: port-mac68k
Date: 04/07/1996 16:33:57
> On Sun, 7 Apr 1996, Jonathan Short wrote:
> > I installed MacBSD on my LCII.  Single-user worked fine.  I tried to add a new user, it told me it was a read-only system.  I then typed exit to get to multi-user mode, and the computer said several things, the last of which were:
> > 	starting local daemons:.
> > 	Sat Apr 6 11:19:20 PST 1996
> > 	Apr 6 11:19:21 init:kernel security changed
> > from 0 to 1
> > The computer said nothing else, there was no prompt, but I could type and the letters came up on the screen.  The computer did not respond to what I typed though.  Did I do something wrong, or is this how far the LCII has progressed at this point? Thanks,
> Sounds like you didn't have a getty running on the console.
> When in single user, do "mount -u /" toi remount the root partition for 
> read-write access.  Then you can add users (use vipw, please!) and you 
> can edit /etc/ttys to set up ttye0 to run a getty.
> then, when you exit to multi-user, you'll get a login prompt after the 
> rest of init finishes.
What do I add to the vipw file?  I mean, exactly what text do I add?  The FAQ was not explicit.  It just said to add the name, but what else do I do? Also, I don't know what a getty is.  What would I do to the file /etc/ttys and with what editor should I do it?  Thanks,
				Jonathan Short