Subject: Re: Serial ports & ppp & cu
To: Christopher R. Bowman <>
From: Bill Studenmund <>
List: port-mac68k
Date: 12/10/1995 11:56:01
> I've been using unix for years as a user and I am picking up bits and
> pieces of administration here and there, but I am having trouble with
> geting my modem to work.  I would eventually like to get ppp up and
> running.  To this end, I have read just about everything I can get my hands
> on that is even remotely related to this.  I wanted to start off by using
> cu to get the modem to dial out.  Unfortuneately I can't seem to get this

It's been my experience that this is a bad place to start. Try "tip"
instead (I think that's the name). It uses a slightly config, but
com0 is the modem port for it. My experience with old binaries was
that cu didn't handle errors gracefully. New binaries might be fine,
but I gave up on cu. I have, however, almost gotten ppp to work.
It dials in fine, and sets everything up. I'm just missing a step to
make ping happy. :-)

> to work.  I have a IIci with 8 megs, a Maccon nubus ethernet card, and a
> zyxel 14.4 modem.  I am running the NFS_14 kernal off eskimo with binaries
> from a post 1.0 snapshot.  I have no trouble getting the modem to work
> under MACos.  I tried the following command: cu -l /dev/tty00 -s 9600 and I
> go the following error: cu: creat (/var/spool/lock/TMP000000005ec):
> premission denied cu: /dev/tty: Line in use.
> I have tried changing the permissions on /dev/tty00, and I have also tried
> the command as root, but I always get the same error.  Can any one lend
> some assitance?

Good luck!