Port-m68k archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Can't build 5.1.2 kernel

Hello Radoslaw,

On Nov 9, 2012, at 9:24 AM, Radoslaw Kujawa wrote:

> ../../../../arch/amiga/amiga/machdep.c:237: error: 'Elf32_Ehdr' > undeclared > (first use in this function) > ../../../../arch/amiga/amiga/machdep.c:237: error: (Each undeclared > identifier is reported only once > ../../../../arch/amiga/amiga/machdep.c:237: error: for each function > it > appears in.)
> *** Error code 1

Maybe you do have options LKM specified in your config file, but don't have DDB? Looking at machdep.c I suspect that could be problematic
 Try adding "options DDB" to you config, compile again and report back.

Also, if possible upgrade to NetBSD 6.

I checked and "options DDB" is not in my kernel config. I will add this and try building again.

Well, my goal was originally to upgrade to 6, but because of all the issues I am having I am still trying to upgrade from 4 to 5. Are many people using NetBSD 6 on port-amiga?

Best Regards,

Home | Main Index | Thread Index | Old Index