Port-i386 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Help with Eclipse 3.4 under NetBSD, emulated or otherwise?

On Thu, Nov 13, 2008 at 08:13:35PM -0800, Scott Presnell wrote:
> Hi,
>       I've been using Eclipse 3.1 native under NetBSD 4.0 for a while, and I
> would like to move up to version 3.4 (Ganymede).  I have tried using the linux
> version (e.g. eclipse-SDK-3.4.1-linux-gtk.tar.gz) with several different JVMs
> (sun-1.5, jdk-1.5.0, jdk-1.6.0 from wip), but with each I end up at the
> following error:
> !ENTRY org.eclipse.osgi 4 0 2008-11-13 20:06:12.046
> !MESSAGE Application error
> !STACK 1
> java.lang.UnsatisfiedLinkError: no swt-gtk-3449 or swt-gtk in 

Okay, a followup on the issue. Sorry for not doing this earlier, but work
has caught me (should I say as usual?). I've come to it on friday finally,
and I realized I was wrong in the version I said. I am trying to get to run
3.5M3 via source build, i.e.  natively. I did succeed in building eclipse
itself with the jdk16.  I built the eclipse binary. I built all the swt stuff
(with gtk).  I don't get any link errors anylonger. But obviously I still
oversaw something, as I still get an error (both using the JNI and the EXEC
style invocation of eclipse) which though lies on the java side of things,
or so I think. I've run out of time to investigate (didn't wanna be locked
in) and will continue this during the upcoming week (don't pin me on a date).
I've not given up yet! :)

For the interested, the error is:

!SESSION 2008-11-21 17:36:40.806 -----------------------------------------------
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=netbsd, ARCH=x86, WS=gtk, NL=en
Command-line arguments:  -os netbsd -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2008-11-21 17:36:43.092
!MESSAGE An error occurred while automatically activating bundle 
org.eclipse.ui.workbench (9).
org.osgi.framework.BundleException: The activator 
org.eclipse.ui.internal.WorkbenchPlugin for bundle org.eclipse.ui.workbench is 

I haven't looked at the java code yet, I assume I still have overseen things
to change to 'netbsd' and/or netbsd environment stuff in some places. As I
said, the quest continues... (I'm happy though that I've moved from C/library
to java errors now. Hopefully the eclipse guys have a better java coding
style than they do show in C!)



Home | Main Index | Thread Index | Old Index