Subject: Kernel hangs during npx0 initialization.
To: None <>
From: =?EUC-KR?B?DQq52r/rwdg=?= <>
List: port-i386
Date: 01/10/2005 17:40:00
I upgraded my machine's CPU from old AMD Athlon 1.0GHz (Thunderbird core)
to Duron 1.8GHz. (Applebred core) And now *BSD
(NetBSD/FreeBSD/OpenBSD/DragonflyBSD...) refuses to boot!

As long as I can see from the kernel's message, the problem is npx0. The
kernel freezes anytime it tries to initialize/detect npx0 in my machine.

I tried to solve problem by configuring kernel differently, but as long as
I enable npx, the kernel refuses to boot.

So much frustrated, I tried Windoze XP and ran some cpu test apps there,
but there seems to be no problem.

Then, I tried Linux. With early versions of linux kernel (I think
something like 2.4.10 or so), the same problem occurs: the kernel fails to
detect FPU correctly and freezes. However, when I tried again using newer
2.6.x (any version) linux kernels, no problem at all!!!

I think the reason for this is the NPX initialization code...As long as I
can see, all flavors of *BSD faces same problem. Linux once had same
problem, but it seems they fixed it. (2.4.x couldn't boot, but 2.6.x can)

So, does anyone had similar experiences? Flawed FPU detection/initialization?