Subject: GRUB + bootxx problem
To: None <>
From: Joachim Thiemann <>
List: port-i386
Date: 12/17/2003 11:39:50
Hello, I have a triple-boot machine (Win, Linux and NetBSD).  I used to have 
it all running nice with grub, the menu.lst file (relevant parts) looking 
like this:

title NetBSD
    root (hd0,1)
    chainloader +1

title Linux
    kernel (hd0,5)/boot/vmlinuz root=/dev/hda6 vga=0x314 desktop acpi=off 
splash=native hdc=ide-scsi hdclun=0 showopts
    initrd (hd0,5)/boot/initrd

title Windows
    root (hd0,0)
    chainloader +1

Grub would load the NetBSD bootloader (that gives the "> " prompt) which 
after a timeout would load the kernel all nice and proper.

Ever since I reinstalled the bootloader (going from, I think 1.6U to 1.6ZE 
of F) all I get after selecting NetBSD is "Error Not a bootxx image".  I 
can boot NetBSD "by hand" by going to the grub console and typing

root (hd0,1a)
kernel --type=netbsd /netbsd

...but since grub doesn't grok the NetBSD kernel args, NetBSD will prompt me 
for root, swap, and init.  Annoying but workable.

I tried installboot with various incantations, but without success. In the 
end I reinstalled NetBSD from scratch using a homemade bootable 1.6ZF image 
made from releng (20031212, I think) and installed the NetBSD MBR 
bootselector which booted NetBSD OK.  (but is unable to boot Linux)

I then reinstalled grub (which is how I did it originally) but I still get 
the same problem.  BTW, I installed grub from the SuSE 9.0 partition (3rd 
primary extended, root in first extended), after booting it from the 
install/rescue CD.

Can anyone help me fix this?