Subject: NetBSD 1.2 and samba
To: NetBSD i386 <port-i386@NetBSD.ORG>
From: Jukka Marin <>
List: port-i386
Date: 06/15/1997 11:02:23
I'm trying to set up a samba server (print server at the moment) on a NetBSD
1.2 box.  When I run nmbd with debug level set to 9, I get this in the log
doing parameter log file = /usr/local/samba/log.%m
doing parameter lock directory = /usr/local/samba/var/locks
doing parameter share modes = yes
pm_process() returned Yes
lp_servicenumber: couldn't find homes
lp_servicenumber: couldn't find printers
lp_servicenumber: couldn't find printers
adding IPC service
services not loaded
Added interface ip= bcast= nmask=
making subnet

Couldn't find printers and homes?  I have tried many different config files
and it's always the same.  Here are some sections of my config file:

   lock directory = /tmp
   printing = bsd
   printcap name = /etc/printcap
   load printers = yes
   browseable = yes
   guest account = test

   comment = Home Directories
   browseable = no
   read only = no
   create mode = 0750

   comment = All Printers
   browseable = yes
   printable = yes   
   public = yes
   writable = no
   create mode = 0700

Are there some special tricks required to make sambe work under NetBSD?
Compile went ok out-of-the-box.  I'm playing with samba 1.9.16p11 if that

Sorry for posting here, but I thought this was a NetBSD specific thing
because a linux config file wasn't working either..



                     ---> <---