Port-hpcmips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD 5.0 on Compaq C-Series 810

I tried the NetBSD 5.0 TX3912 kernel on a Compaq C-Series 810 with 8MB system 
ram.  Unfortunately, this release kernel has the same problem that I've seen on 
previous kernels.  It hard hangs just after the PCMCIA probe of the flash card.

There was mention of a workaround in April 2006 of the archives by someone with 
a 2010c model.  (Almost the twin of the 810)  They were getting this same hang 
using a 3.x kernel.  They simply popped the flash card out right after psdboot 
loaded the kernel, then stuck it back in.

I tried this, and the kernel does very quickly move up to a "root device:" 
prompt.  (Faster than one can re-insert the flash card.)  Unfortunately no 
variation of wdc0, wd0a, wd0, etc. gets me past this prompt after I re-insert 
the flash.  It just keeps returning that prompt.

I have also noticed that it does not post any messages when I re-insert the 
card, so possibly it is not detecting it with late insertion.

I saw in Feb - March of 2007, someone with a 2010c had managed to get their 
system up, but there was no reference to which kernel, etc.

I have tried all 3.x kernels, 4.x kernels, and a few -current, etc from various 
release tags.  Nothing seems to work on the 810 after the 2.1 release kernel.


Home | Main Index | Thread Index | Old Index