Subject: Re: New kernel behavior [was] Re: z50 TrackPoint driver for CVS...
To: Adam K Kirchhoff <>
From: billy ball <>
List: port-hpcmips
Date: 04/05/2002 17:26:29
On Fri, 5 Apr 2002, Adam K Kirchhoff wrote:
> On Fri, 5 Apr 2002, billy ball wrote:
> > 3. started X and trackpoint and LCD blanking works! D-Link wireless card 
> > turns off and on in response to power-button presses; trackpoint action is 
> > stable and restored! - yahoo!
> LCD blanking while in X?

yes, LCD blanking while using X seems to work fine...

> > 4. using:
> > 
> > shutdown -r now
> > 
> > results in a reboot back to NetBSD, but with a white console (black text 
> > on white); is there some way to create a persistent setting for white text 
> > on a black screen?
> Not for me.  When I reboot, I still get the white text on a black screen.

hmmm... that's interesting!

> I can't seem to force it to reboot into WinCE.  I have to do a shutdown -h
> now, but then, once the system is halted, I still have to pull the battery
> out :-)

if i perform 'shutdown -h now' from the black text/white background 
console, the unit reboots to WinCE...

also, upon 'shutdown -r now' from the white text/black background, the 
audio0 device is not reported... i also tried using mknod to create the 
sound/0, audio/0, mixer/0, and audioctl/0 devices (major number 47 and 0, 
128, 16, and 192, right?)... but cannot seem to play sound and get:

"device not configured"...

ah well... the LCD blanking *and* trackpoint support is still good! (i can 
work around the shutdown problems)...