Subject: Few niggles with installation on jornada 720
To: None <>
From: Mark Kirby <>
List: port-hpcarm
Date: 01/10/2006 16:20:53

I have just installed current (and current X) on to my jornada 720. I seem to 
be having a few problems. I'll list the steps i took to get it installed and 
then the problems im having.

1st i disklabeled my 1gb kingston flash card setting up a dos partition, a 
netbsd partition and a swap partition. That all worked fine.

I then did a ./ -x -m hpcarm distribution and installed that on the 
flash card. I ran postinstall and ran the commands it suggested, then coppied 
the built /etc over to the flash disk. uudecode'd hpcboot and copied 
that over aswell as the new kernel. I created a symlink on / pointing to 
netbsd on the dos partition.

I then noticed that the MAKEDEV script didnt exist so i copied those over and 
built my devices.

I set my rc.conf up and booted up the jornada.

It booted up fine with the japanese option.

Now my problems.

On boot syslog complained that authlog, cron, xferlog, lpd-errs and mail log 
were missing. 

root obviously had no password at this point and non of his user files 
(.cshrc .login etc) were present.

Is there a command to create them? In the end i coppied them from another 

The permisions on /tmp were wrong, only root had read write access. chmod 777 
fixed that.

X as root is fine but i cannot start it as a normal user. It just complains 
there are no screens available.

also the ctrl key in X does not work by default i had to add 
clear control
addcontrol = Control_L

to xmodmap.

X also switches the screen of after 10 mins regardles of whether im typing or 

If anyone knows what i have done wrong with setting it up i would appretiate 
any help as i plan on writing this up for the new wiki.


The NetBSD CVS Digest