Subject: Latest snapshot on B160L
To: None <>
From: Gheorghe Ardelean <>
List: port-hp700
Date: 06/01/2005 00:44:37

I have installed the latest snapshot from
onto my B160L via netboot. Install was ok but after rebooting I get:

NetBSD/hp700 FFS/LFS Primary Bootstrap

32bit firmware

booting from partition a
filesystem: FFS
looking up boot.hp700
looking up boot
looking up usr/mdec/boot
no secondary boot found


Have I missed some required steps during the install?
To fix I had to reboot via network the netinstall.lif
than go to shell and:

# mount /dev/sd0a /mnt 
# mount /dev/sd0d /mnt/usr
# cp /mnt/usr/mdec/boot /mnt

# mount
/dev/md0a on / type ffs (local)
/dev/sd0a on /mnt type ffs (local)
/dev/sd0d on /mnt/usr type ffs (local)

Now after reboot I get a usable system.
I am going now to compile some packages.
Thanks for the good job.


Gheorghe Ardelean.

Here is the dmesg:

Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
     The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
     The Regents of the University of California.  All rights reserved.

NetBSD 3.99.5 (GENERIC) #0: Sun May 29 01:27:50 UTC 2005
HP9000/778/B160L (Merlin L2 160)
real mem = 256 MB (73728 reserved for PROM, 233 MB used by NetBSD)
avail mem = 229 MB
mainbus0 (root) [flex fff80000]
pdc0 at mainbus0
cpu0 at mainbus0 hpa 0xfffbe000 path 62 irq 31 ipl 0: PA7300LC (Velociraptor) rev 4
cpu0: PCX-L2, PA-RISC 1.1e, lev 1, cat A, 160 MHz clk
cpu0: shadows, 64K/64K D/I caches, 96 shared TLB, 8 shared BTLB
cpu0: VR floating point, rev 1
mem0 at mainbus0 hpa 0xfffbf000 path 63: size 256MB
phantomas0 at mainbus0 hpa 0xffc00000 path 8
dino0 at phantomas0 hpa 0xfff80000 path 8/0 irq 28 ipl 1: Dino V2.1
pci0 at dino0 bus 0
pci0: i/o space, memory space enabled
lasi0 at phantomas0 hpa 0xffc00000 path 8/16 irq 27: rev 3.0
gsc0 at lasi0
lpt0 at gsc0 hpa 0xffd02000 path 8/16/0 irq 7 ipl 1
harmony0 at gsc0 hpa 0xffd04000 path 8/16/1 irq 13 ipl 2: rev 18
audio0 at harmony0: full duplex
com0 at gsc0 hpa 0xffd05000 path 8/16/4 irq 5 ipl 3: ns16550a, working fifo
com0: console
osiop0 at gsc0 hpa 0xffd06000 path 8/16/5 irq 9 ipl 4: NCR53C710 rev 2, 40MHz, SCSI ID 7
scsibus0 at osiop0: 8 targets, 8 luns per target
iee0 at gsc0 hpa 0xffd07000 path 8/16/6 irq 8 ipl 5: Intel 82596CA address 00:60:b0:17:c8:a3
gsckbc0 at gsc0 hpa 0xffd08000 path 8/16/7 irq 26 ipl 6: keyboard
gsckbc1 at gsc0 hpa 0xffd08100 path 8/16/8: mouse
wax0 at phantomas0 hpa 0xffe00000 path 8/20 irq 26
gsc1 at wax0
"Core HIL" at gsc1 (type 0xa, sv 0x73) hpa 0xffe01000 path 8/20/1 not configured
com1 at gsc1 hpa 0xffe02000 path 8/20/2 irq 6 ipl 7: ns16550a, working fifo
"WAX EISA Bus Adapter" at gsc1 (type 0xb, sv 0x90) hpa 0xfc000000 path 8/20/5 not configured
sti0 at phantomas0 hpa 0xf8000000 path 8/24: INTERNAL_EG_1280 rev 8.07;9, ID 0x2d08c0a709a02587
sti0: 2048x2048 frame buffer, 1280x1024x8 display, offset 0x0
sti0: 8x16 font type 1, 16 bpc, charset 0-255
biomask 00000310 netmask 00000330 ttymask 000007fa
wsdisplay0 at sti0 kbdmux 1
wsmux1: connecting to wsdisplay0
Kernelized RAIDframe activated
scsibus0: waiting 2 seconds for devices to settle...
sd0 at scsibus0 target 0 lun 0: <SEAGATE, ST15230N, 0252> disk fixed
sd0: 4095 MB, 3992 cyl, 19 head, 110 sec, 512 bytes/sect x 8386733 sectors
sd0: sync (100.00ns offset 8), 8-bit (10.000MB/s) transfers
sd0: fabricating a geometry
boot device: sd0
root on sd0a dumps on sd0b
sd0: fabricating a geometry
sd0: fabricating a geometry
root file system type: ffs