Subject: Re: A180C
To: Jochen Kunz <>
From: Andy Ruhl <>
List: port-hp700
Date: 07/02/2004 21:45:03
On Wed, 23 Jun 2004 23:14:30 +0200, Jochen Kunz
<> wrote:
> On Wed, 23 Jun 2004 12:52:34 -0700
> Andy Ruhl <> wrote:
> > Wondering if anyone has booted NetBSD on an A180C.
> Give me your A180C and I will boot NetBSD on it. ;-)
> At the moment NetBSD may be only of limited use on this machine. The
> A180C has PCI Ethernet and NetBSD has no PCI support yet. But I am
> currently working on porting the OpenBSD/hppa PCI code to NetBSD. Note
> also that NetBSD/hp700 is not stable enough for real world use at the
> moment.
> > I see OpenBSD supports it.
> Yes. I have a B180L that is quite similar to the A180C. I instaled
> OpenBSD 3.5 on my B180L and it worked quite good.
> > Anyway, wondering how to install on a machine with no way to boot off
> > of removeable media 
> Netboot it. All you need is DHCP, tftp and NFS. There is

Ok, I finally got the thing to netboot an OpenBSD kernel from my
NetBSD/sparc64 server. Problem is, the serial port on the sparc
machine doesn't work for the serial console on the A180C, so I had to
babysit it with my laptop. I tried to boot NetBSD, netbsd-SMALL.lif,
but all I got was a bootloader claiming that it couldn't find the
kernel from whatever interface it was using (lf0? lif0?). I saved the
output somewhere but I can't find it.

If you have a kernel you'd like me to boot to get a dmesg from it or
something, let me know.

Oh, I used bootpd and tftpd just to get the kernel running. I'm not
quite sure how dhcpd bootstraps a kernel... I'll have to look into
that. I'm familiar with how to use it after the kernel is loaded

It looks like OpenBSD's boot kernel can install the OS as well which
is pretty nice. Wish I knew code better or I'd start into NetBSD to
get this working. There's an A180 on Ebay for $31 right now. Not bad
at all. If it runs OpenBSD OK or Linux (ugh, I don't like Linux), it
could still be useable as I keep trying NetBSD...

Tried to cross build a kernel on NetBSD/i386 and it didn't work.
Complaining about the config part. Something about wlan? I'll get back
to it...