Subject: Re: NetBoot HP9000/400 is broken since 1.41 ?
To: None <>
From: Bernd Sieker <>
List: port-hp300
Date: 05/09/2005 21:50:10
On 09.05.05, 19:47:17, Djeezus wrote:
> Hy all,
> i've been using NetBSD for some time to run on my HP9000/400 system;
> the disks are fried so I run it diskless.  But now I wonder why on

Older, smaller SCSI disks are really cheap on ebay these days, if
the fried disk is the main reason for using netboot.

> earth there's no "netbsd.DISKLESS.gz" anymore since the 1.4.3 release
> ?
> I've tried using the 1.6.2 SYS_UBOOT together with 1.4.1
> netbsd-DISKLESS.gz,  i boot the HP, select "SYS_BOOT" from network
> boot menu ... it loads fine and show user interface .... but the
> SYS_BOOT images does nothing after I hit [return] on the HP box
> keyboard ... this is where it should start doing its rarp lookups and
> getting its bootinfo from the bootparamd and so on ... but it seems to
> be lacking support for doing rarp lookups.
> All i get from the HP box is this (tcpdump log) :
> 19:37:36.160886 >  file ""[|bootp]
> Is there something broken or am I missing something that's not broken ;-)

I don't have 1.6 sources lying around any longer, but in 2.0 the
GENERIC kernel can boot diskless. But the only protocol it speaks
to get boot information is BOOTP. It no longer uses the obsolete
rarp/bootparam. Since the HP prom doesn't use rarp, either (but
HP's proprietary rboot protocol), this is not really a loss.

dhcpd can answer bootp requests. I haven't tried very recently,
but I have booted 2.0_BETA and 2.0_RCn snapshots via network on my

> thnx & bye,
> gert

Bernd Sieker

NetBSD: userland included