Subject: a.out recent openssh for m68k?
To: None <>
From: Chris Rupnik <>
List: port-hp300
Date: 09/16/2003 17:41:14
 I have a hp425 running 1.5 (a.out)
I would like a more recent ssh, and unfortunately, the one in pkgsrc is ELF.

hp300# file /usr/pkg/sbin/sshd
/usr/pkg/sbin/sshd: ELF 32-bit MSB executable, Motorola 68000, version 1,
dynamically linked (uses shared libs), stripped

Whereas the one that I have is a.out

hp300# file /usr/sbin/sshd
/usr/sbin/sshd: NetBSD/m68k demand paged dynamically linked executable

hp300# uname -a
NetBSD hp300 1.5 NetBSD 1.5 (GENERIC) #8: Sun Nov 19 21:36:31 MET 2000 hp300

so, I tried to download pkgsrc and compile my own to get an a.out version.
Well, that didn't get too far. I guess my tools are too old?

hp300# make
"Makefile", line 33: Could not find ../../mk/
"Makefile", line 72: Malformed conditional (${OPSYS} == "Darwin" || ${OPSYS}
"Makefile", line 72: Need an operator
"Makefile", line 73: Could not find ../../security/skey/
"Makefile", line 75: if-less elif
"Makefile", line 75: Need an operator
"Makefile", line 79: if-less else
"Makefile", line 79: Need an operator
"Makefile", line 81: if-less endif
"Makefile", line 81: Need an operator
"Makefile", line 151: Could not find ../../devel/zlib/
"Makefile", line 152: Could not find ../../security/openssl/
"Makefile", line 153: Could not find
"Makefile", line 155: Could not find ../../mk/
Fatal errors encountered -- cannot continue

So, besides upgrading to 1.6 (not an option due to unsupported graphic
console), what do you recommend?