Subject: diskless booting a HP9000/340
To: None <>
From: \"=?ISO-8859-1?Q?H=E5kan Th=F6rngren?=\" <>
List: port-hp300
Date: 01/29/2003 12:35:25
I recently got a HP9000/340 with an HP-IB disk and tape station,
monitor and keyboard.  The company I work for was about to toss it.
They were the first owners, and I took pity on the machine, although I
know this machine has always been hopelessly slow.  Too little RAM and
a slow disk...  The main reason for getting it was in case I ever get
some HP-IB device, and I felt sorry that they wanted to throw it away.

I have successfully booted some Sun 3/60 machines diskless, now the
turn comes to a getting a HP9000/340 to boot diskless using NetBSD
1.6. The boot server is a NetBSD/Sparc 1.5.1 machine (have not come
around upgrading it yet).
I hooked up a VT320 terminal (that they also wanted to toss) to it and
attached it to the network, no other devices are attached at the

I will describe the process rather than showing all actual output
since it happens on the VT320 terminal.

Boot starts with rbootd, the HP gets the SYS_UBOOT (from 1.6
distribution), then the HP asks the dhcpd server for information and is=

given the proper IP number and server IP.  It also gets the root file
system from the dhcpd server.

The HP mounts the root file system and loads the kernel.

First I tried with the generic kernel, but it fails early saying it
cannot allocate buffers since it runs out of memory.  The 340 only has

I then tried a second kernel from the distribution, something with a
ram disk.  This ones comes further:
boot device le0
root on md0a dumps on md0b
WARNING: clock gained a lot of days..
root file system type: ffs
erase ^?, werase ....
UVM: pid 6 (sh), uid 0 killed: out of swap

It seems to have found some memory disk to use and runs out of memory?

Obviusly, I was in need of a simple small kernel for diskless boot,
there seems not to be any in the distribution.  I then took a wild
shot and built a kernel using one of the Sun3 machines. They are also
68K and share binaries with the hp300.  I created a configuration
and directed it into the hp300 compile directory and created a kernel.

This kernel fails in the following way after it has identified the

boot device: le0
root on le0
no file system for le0
cannot mount root, error =3D 79
root device (default le0): <blinking cursor>

If 79 is an errno number, it means "Inappropriate file type of

I assume it wants to remount the root file system, but fails to
understand where to get it.
(I have also set up /etc/ethers and /etc/bootparams as with the sun3s)

Is there someway I can make it understand how to find the nfs root
file system?
Will this kernel work at all, being built on a sun3?
Is there some small simple diskless kernel available that works