Subject: Re: Working hp300 network boot code!
To: None <>
From: Tomas Tengling <>
List: port-hp300
Date: 09/14/1995 17:29:10
> I'm happy to announce new working network boot code for NetBSD/hp300.

I tried it today and after a few problems it works great!

The problems I had was with the device files.  I have a hp345 which boots
diskless with root/swap at a hp735.  When I thought that I had set everything
up and put in the latest binary snapshot it hanged after 'root on... swap on..'.
It turned out that there were no device files in the snapshot so I tried
to make them by hand in the exported root on the 735.  Then the 345 at
least could boot up in singleuser and I could see that the device files
had the wrong major number.  I tried to make new ones at the 345 but it
refused to make device nodes on a nfs mounted file system so I had to
get back to the 735.  

There, after some tries I found out that 'mknod foo c 1 2' on the NetBSD
side was equivalent to 'mknod foo c 0 0x0102' on the HP-UX side.  After
that discovery I could create the device files with the correct major

Is device files over nfs supposed to be different under different OS?

Shouldn't it be possible to create device files on a diskless client?


  Chalmers   |  Tomas Tengling                | Email:
 University  |  Kolonigatan 3                 |
     of      |  S-413 21  Gothenburg, Sweden  |
 Technology  |  Phone: +46 31 163853          | Fidonet: 2:203/125