Port-evbmips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: RB133

On Fri, Feb 15, 2008 at 07:13:48PM +0100, Ji?? Smejkal wrote:
> I'm using RB153 (six eth ports) wih NetBSD. It works well.
> I have tried RB133 (three eth ports) and 133C (only one eth port) - 
> there is some strange behavior - board netboot o.k. but then can't attach
> NFS.
> Boot device on board is admsw0, when board try attach NFS the device 
> change to admsw2 and attach fails. I tried change vlan_matrix in 
> if_admsw.c (1 << 0) swap to (1 << 2) and then board boot and attach NFS
> properly but this is not solution.

It sounds as if the hardware and/or BIOS "swizzles" the ports (i.e.,
port 2 -> vlan 0, port 0 -> vlan 2) and NetBSD does not respect that.
Does that sound right to you?

NetBSD should probably honor the VLAN matrix that is programmed by
the BIOS.  I will write a patch for that, if no one beats me to it!


David Young             OJC Technologies
dyoung%ojctech.com@localhost      Urbana, IL * (217) 278-3933 ext 24

Home | Main Index | Thread Index | Old Index