Subject: Re: SegFaults
To: None <>
From: Kevin <>
List: port-dreamcast
Date: 08/05/2001 19:45:54
I'm going to be horribly unhelpful here but I ran into the exact same
situation.  Many of the /bin binaries were segfaulting.  I think I found
that ksh did not (I could be wrong, this was a while ago) and replaced
/bin/sh with /bin/ksh.  If I get a chance later I will boot up my
dreamcast again and see which userland binaries I'm currently using
because I know I tried a second set which seemed to work better.  Like I
said, horribly unhelpful, but know that you are not alone ;).

On Sun, 5 Aug 2001, Patrick Muldoon wrote:

> Date: Sun, 5 Aug 2001 19:32:18 -0400 (EDT)
> From: Patrick Muldoon <>
> To:
> Subject: SegFaults
> Hello all,
> I have been reading over the list and trying to get NetBSD to boot on my
> dreamcast.  I have the slave boot loader setup, got my dhcp server, and
> nfs server set,  got the userland files installed and the such. I can boot
> the kernel found on, but then I run into the same
> problem that Matt Harrington ran into with is segfaulting on /bin/sh with
> the error message tlb_handler#NOGO:va(0xb3000,spc=4b8ba
> Segmentation fault (core dumped).
> I see a mention of marcus's kernel and a link to
> which doesn't seem to be working at the moment.  I was wondering if
> someone could either point me to a new place to get a kernel that might
> work better then the one that I have.
> Thanks in advance
> Patrick
> I am using NetBSD 1.5S compiled on Feb 23