Subject: Broken hardware?
To: None <>
From: Fredrik Hubinette <>
List: port-dreamcast
Date: 05/18/2001 23:50:25
Hello everybody,

I've been trying to get NetBSD to run on my DC, but I've had
very little success. I've gotten to the point where the DC
has received an IP number and mounted the root filesystem, but
when trying to load /sbin/init it hangs. I've been snooping
the network, and the DC starts sending read requests, and the
NFS server is replying, but then the DC seems to turn deaf or
something... I suspect that the dreamcast is having problems
with large (8Kb) packets. The last message on the the screen is:

     init: copying out path '/sbin/init' 11

Has anybody experienced anything similar?

I'm inclined to think this is because of broken hardware, because
the same BBA does not seem to work for playing Quake either.
(It connects, but is unable to list Quake servers) However, I
suppose it could be hardware limitation and/or driver issue as well.

I got the kernel from Marcus Comstedt, it boots beautifully from
a CD. The NFS rsize has been set to 8Kb, so the BBA *should* be
able to recive the whole packet. I've tried using both Linux
and FreeBSD NFS servers with the same result.

Is there anything I can do to verify weather the BBA is broken,
or not?


PS: I'm new to this list, but I've been poking around the archive
    quite a bit without finding anything that seemed relevant.

PSS: A search function for the mail archive would be very helpful. :)