Subject: Re: After newlock2 merge: Different pthread behavior for userland programs?
To: Andrew Doran <>
From: Markus W Kilbinger <>
List: port-cobalt
Date: 03/21/2007 22:36:20
>>>>> "Andrew" == Andrew Doran <> writes:

    Andrew> On Wed, Mar 21, 2007 at 07:13:50PM +0100, Markus W
    Andrew> Kilbinger wrote:

    Andrew> Ok, I was hoping they would be solved by the latest fixes
    Andrew> :-). That one
    Andrew> (36008) is next on my list to look at.

My previous failing perl's 'make test' was w/o your recent kernel and
libpthread changes (today before 18:00 UTC).

I just resynced with your latest changes several minutes ago and can
confirm that now perl's 'make test' passes the ext/threads part
flawlessly, too! Thanks! (Close pr/36008?)

    Andrew> It might be better to sort the perl problems first and
    Andrew> then try asterisk after that..

So, I've updated my qube2, too, and will observe how it works now with
asterisk the next days...

    Andrew>  I'll update pkgsrc and try again. Are you sure that your
    Andrew>  thread library and kernel are up to date?
    Andrew>  Can you see something that I am doing differently?

The problem seems to be solved! I was missing your latest changes.

Thanks again,