Subject: Re: Java and Qube 2 (NetBSD 3.99)
To: Robert Lougher <>
From: Kenth Andersson <>
List: port-cobalt
Date: 08/22/2006 08:45:21

I'm not getting that far, I'm trying to compile jamvm, but the  
compilation stops in gnu classpath 0.91 due to a out of memory error.

I've got 256mb (max) in the Qube2 and I've increased the swap to 628  
mb (128 standard + 500 added with swapctl -a)
but I still get "Out of memory" error in jikes when compiling classpath.

Have anyone compiled gnu classpath 0.91 on netbsd 3.99 and got it  
working, maybe someone got a pre compiled package?

Any hints about whats happening?
Why is jikes trying to eat all my memory?


On 18 aug 2006, at 23.21, Robert Lougher wrote:

> Hi,
> What version of JamVM are you using (do jamvm -version)?  Also, did  
> you try
> to increase the maximum heap size using -Xmx?  E.g.
> jamvm -Xmx192m <...>
> By default JamVM has a maximum heap size of 128MB.  If you're using a
> version older than 1.4.3 I'd suggest upgrading, as 1.4.3 has a  
> compacting
> garbage collector, which requires less memory to run.
> Rob.
> Kenth Andersson-2 wrote:
>> Hi,
>> I've seen two mailes about this on the list before, but can't find
>> any answers.
>> Is there anyone that as successfully compiled (pkgsrc) any java vm on
>> the Qube 2 running NetBSD 3.99 (restore CD installation)?
>> I've tried jamvm, kaffe and suns own jre, non of them seams to  
>> compile.
>> jamvm is the one that gave me greatest hope, but crashed in gnu
>> classpath due to "Out of memory" error, I got 256MB (Max mem size) in
>> my Qube, seams like jikes is heavy on memory usage.
>> Would be great if anyone could come with input and maybe some
>> solutions and recommendations.
>> Thanks,
>> Kenth Andersson
> -- 
> View this message in context: 
> %28NetBSD-3.99%29-tf2128923.html#a5877729
> Sent from the port-cobalt forum at