Subject: ohci0: 2 scheduling overruns
To: None <>
From: Dennis <>
List: port-cobalt
Date: 06/15/2006 19:35:53
Hi again!

So the build and reboot with the new kernel worked like a charm. After 
the reboot I took a look at dmesg and I got only a lot of these lines: 
ohci0: 2 scheduling overruns!
Nothing else!
So I pluged in my HL 2030 printer and got:

ugen0 at uhub2 port 2ohci0: 2 scheduling overruns
ohci1: 2 scheduling overruns
ohci2: 3 scheduling overruns

ugen0: Brother HL-2030 series, rev 2.00/1.00, addr 3

Then I gave my IPod a try and got:

ohci0: 2 scheduling overruns
umass0 at uhub2 port 1 configuration 1 interface 0
umass0: Apple iPod, rev 2.00/0.01, addr 2
umass0: using SCSI over Bulk-Only
scsibus0 at umass0: 2 targets, 1 lun per target
sd0 at scsibus0 target 0 lun 0: <Apple, iPod, 1.62> disk removable
sd0(umass0:0:0:0):  Check Condition on CDB: 0x00 00 00 00 00 00
    SENSE KEY:  Not Ready
     ASC/ASCQ:  Logical Unit Is in Process Of Becoming Ready

sd0: drive offline
ohci0: 12 scheduling overruns
ohci1: 12 scheduling overruns
ohci2: 11 scheduling overruns
ohci0: 2 scheduling overruns

Then I just tried:
qube# fdisk /dev/sd0
Disk: /dev/sd0d
NetBSD disklabel disk geometry:
cylinders: 1953, heads: 64, sectors/track: 32 (2048 sectors/cylinder)
total sectors: 3999744

BIOS disk geometry:
cylinders: 248, heads: 255, sectors/track: 63 (16065 sectors/cylinder)
total sectors: 3999744

Partition table:
1: Primary DOS with 32 bit FAT (sysid 11)
    start 160656, size 3823464 (1867 MB, Cyls 10/0/7-248)

So it seems like it works!

I have no idea what is going on? I just followed this guide:

Can somebody explain what the "error" means and is it necessary to fix it?

And thanks for the fast and good replies to my last couple of question!