Subject: Re: Netbsd 3.0 Crash on file transfert
To: Izumi Tsutsui <>
From: Thierry Rangeard <>
List: port-cobalt
Date: 03/17/2006 17:47:54

I tried nothing special, it was during a scp transfert with a large =20
100MB file. As you could see in the stack trace the stopped process =20
was ssh.

Here below the Trap:

Trap: TLB miss (load.inst.fetch) in Kernelmode status=3D0x2403,
cause=3D0x8, epc=3D0x810cfde0, vaddr=3D0xcc708000 pid 911
cmd=3Dsshd usp=3Dox7fffd4f0 Ksp=3D0xcc6ebb08
stopped in pid 911.1 (ssh) at kernel:r5k_pdcache_wb_range_32+0x9c: =20
cache 0x19, 0x3c0(a0)

You are right on the lockmgr it happens but for the TLB miss I can =20
reproduce it with the same scenario as describe above.

kernel Build 20060313000Z-obj.
Memory installed 256 MB.

Is there a sysctl parameter that I can use ?


Le 17 mars 06 =E0 17:28, Izumi Tsutsui a =E9crit :

> In article <>
> wrote:
>> I tried  the latest NetBSD Build, but nothing   new.
> What exact version did you try?
>> It seems but
>> you have also that feeling because I read a               tonnes of
>> email regarding memory crash issues and in one  of your email you
>> have suspected the R5200 CPU plateform.
> I'd like to know if all crashes reported here are the same problem
> or not. A problem I saw is TLB miss on cache flush, but I don't see
> lockmgr panic on my RaQ2. I wonder if options DIAGNOSTIC makes some
> differences on assertions, but not sure.
> There is also a report that the latest netbsd-3 branch works fine,
> but I haven't tried it.
>> I am not a debugger expert, I can make some test that it.
> As noted in the documentation page, output of stack trace
> on ddb by trace command could help. The lockmgr panic could
> happen with various reason so more info is needed anyway.
> ---
> Izumi Tsutsui