Subject: Compile PF in kernel on Cobalt is no go on 3.0
To: None <>
From: Daniel Ouellet <>
List: port-cobalt
Date: 01/06/2006 03:06:34
I tried a few times to enable PF and so far, I can't even compile the 
kernel with it enable.

As far as I can see, only these needs to be commented out:

pseudo-device   pf                      # PF packet filter
pseudo-device   pflog                   # PF log if

as by default it is not in the GENERIC kernel.

I have no problem making any changes to the kernel and get it to 
compile, but this two line to turn it up as far as I can see, result in 
no go.

I wish I had the error to put here, but as it takes a long time to 
compile, I did it in the background and sing off, so, I didn't see the 
errors the last time, but no matter what variation I do, still no go.

Anyone able to do so yet? Am I forgetting to do something else as well.

Also, in default there isn't a PF device in the /dev, so I use makedev 
to create it, not sure that it is the proper way for this one however.

Any clue to offer?