Subject: Re: date on raq1
To: Oliver Schonefeld <oschonef@TechFak.Uni-Bielefeld.DE>
From: FireWire BSD <>
List: port-cobalt
Date: 12/20/2005 19:47:09
  Thanks, I tried the patches for 2.x it worked fine, but i am not sure
if there any side effects so i decided to upgrade to 3.0 (i would do it
one day or another) but the kernel doesn't boot, here are the details :

I cvs to 3.0 then build tools then build kernel (generic without dma),
before going further i tried to boot on the new kernel, i copied it
to /netbsd.3 then from the boot manager i typed it then it stops, here
are the lines :

>> NetBSD/cobalt 2.1.0_STABLE Bootloader, Revision 0.1 [@0x80f00000]
>> (root@xxxx, Fri Dec  9 23:59:49 CET 2005)
>> Memory:              131072 k
>> PROM boot string:    root=/dev/hda1 ro
Boot [wd0a:netbsd]: wd0a:netbsd.3
Loading: wd0a:netbsd.3
2310880+147260 [82960+74386]=0x27ec3c
Starting at 0x80001000

Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 3.0 (COBALT) #0: Tue Dec 20 10:50:04 CET 2005
total memory = 128 MB
avail memory = 122 MB
mainbus0 (root)
com0 at mainbus0 addr 0x1c800000 level 3: st16650a, working fifo
com0: console
cpu0 at mainbus0: QED RM5200 CPU (0x2810) Rev. 1.0 with built-in FPU
Rev. 1.0
cpu0: 16KB/32B 2-way set-associative L1 Instruction cache, 48 TLB
cpu0: 16KB/32B 2-way set-associative write-back L1 Data cache
panel0 at mainbus0 addr 0x1f000000
gt0 at mainbus0 addr 0x14000000

Then nothing happens for hours.

Do you have any idea? could it be the bootlader that it old?

Thank you again

On Wed, 2005-12-14 at 11:37 +0100, Oliver Schonefeld wrote:
> Hi,
> Eines schoenen Tages schrieb Hubert Feyrer:
> > On Tue, 13 Dec 2005, FireWire BSD wrote:
> > >Any help is welcomed,
> > 
> > Maybe try -current and see if it still happens there?
> > If so, posting this to tech-kern@ may get a bit more/better attention.
> Just a short FYI:
> I've been running 3.0_RC3 for a while on a RAQ1. The Clock ist working fine.
> I also have some clock patches for NetBSD versions prior to 3.0, but I
> cannot remember, if they were for 1.6.x oder 2.x.
> Best Regards,
> Oliver