Subject: Re: 2.1 Kernels do not boot when booted with bootloader other than netbsd bootloader.
To: Alex Pelts <>
From: Andy Ruhl <>
List: port-cobalt
Date: 11/20/2005 17:56:48
On 11/20/05, Alex Pelts <> wrote:
> Some additional information:
> CoLo is able to execute generic 2.1, 2.0.1 and 3.0-RC1 kernels. They are
> too big for native bootloader. Unfortunately all of these kernels get
> stuck at "Kernelized RAIDframe activated" line, when booted over the
> network. I guess they would be not good for restore environment.
> Also colo is able to boot generic 1.6.2 kernel to the prompt but kernel
> is unable to obtain ip address for some reason. Server does not see dhcp
> requests from that kernel.
> Another note : default config, that comes with the 2.1 cobalt, getting
> bus error while processing GENERIC or any other config file derived from
> GENERIC. I had to compile config that comes with kernel source in order
> to compile my custom kernel. This may be the source of my problems.

I've netbooted a 3.0_BETA kernel with the GENERIC config file. Hmm...
I haven't tried anything in 2.x higher than 2.0.2. 2.0.2 was working
though. The release of 3.0 is imminent, are you willing to give it a

Here's the link:

I haven't tried to boot this binary set, but I just built 3.0 a few
weeks ago so I'm not sure it's hugely different. I am, however, using
a patched kernel that Izumi put up. I don't know if that patch made it
into this binary set. If not, you should grab that kernel.