Subject: 2.1 Kernels do not boot when booted with bootloader other than
To: NetBSD <>
From: Alex Pelts <>
List: port-cobalt
Date: 11/20/2005 10:46:46
I am trying to create restore environment hosted on cygwin and I run in 
to following problem - 2.1 kernel does not boot when booted with 
bootloader other than netbsd. I actually tried 2 different ones - qube 
native bootloader and colo. Both of these are able to boot 1.6.1 kernel 
that I took of restore cd but nether of them is able to boot 2.1.

I have two kernels that I compiled and both of them boot from disk. They 
are booted by netbsd bootloader. When I try to boot them over the 
network with colo or builtin qube firmware they get stuck after 
following lines:
invalid bootinfo (standalone boot?)
[ Kernel symbol table missing! ]

These are the last lines I see, and nothing happening anymore. What 
could be causing this ? Next I will try GENERIC kernel, but I suspect 
that I will get the same result.

Anyone is willing to help me? Kernels past 2.1 may have this problem as