Subject: Re: Net boot question
To: <>
From: Alex Pelts <>
List: port-cobalt
Date: 11/17/2005 12:01:37
I tried netbooting colo and getting in to command prompt and it worked. 
Now the question is if colo can netboot a netbsd kernel.

I am still unable to netboot the 2.1 kernel directly. I recompiled it 
according to FAQ and all the manual pages I could find. The same issue. 
1.6.1 kernel still boots fine from cygwin.

I think something in the new 2.1 kernel makes it unbootable by qube's 
bootloader. I wonder if that is something to worry about.


Andy Ruhl wrote:
> On 11/15/05, Alex Pelts <> wrote:
>>When netbooting using 2 buttons method there is no 1st stage bootloader
>>involved. So I beleive I am correct at least on 4. I am probably wrong
>>on 5. Not exactly wrong but impresise - root location is defined by
>>dhcpd config statement so you probably can change it. I have not tried
>>So far my problem has been in booting the kernel. I will try to
>>recompile it again and see how it goes.
>>bfd command is just that - "boot from disk". I want to do complete
>>netboot with kernel residing outside of the qube as well. One thing is a
>>bit alarming to me - kernel size is growing as it progresses and there
>>is no network 1st stage bootloader. As kernel is unable to boot on the
>>cube over the network, only older versions of netbsd can be used as host
>>to the recovery environment. I wonder if we can use CoLo as a 1st stage
> Ok, I get it now, thanks.
> Would be nice if the NetBSD bootloader could do netbooting, that would
> of course be the first choice, but it might be worth seeing if CoLo
> can do it too. I'm downloading now. I might try it with the
> /usr/games/.doug method (mash all 4 buttons at boot).
> Andy