Subject: Why did I upgrade? Non stop problems!
To: NetBSD <>
From: Alex Pelts <>
List: port-cobalt
Date: 11/07/2005 18:15:38
I tried to upgrade my qube to netbsd 2.1 from 1.6.2. What bug bit me I 
don't know :(.

After compiling new 2.1 kernel and booting it, I unpacked the sets 
checked rc.conf and rebooted the box. The kernel would not come up! I 
tried to pass parameter to boot 1.6.2 kernel, I preserved but the shell 
would exit with signal 12 (What is signal 12 on netbsd by the way?).
After numerous attempts at recovery, I finally restored the box with 
restore cd I found online, which turned out to be netbsd-current. Not 
prepared to run current I redownloaded 2.1 and downgraded the box to it.

I though the problems are over. Wrong! After downloading current pkgsrc 
using sup nothing compiles! I mean nothing out of pkgsrc.
Some sort of include file confict. After being impressed by netbsd for 
more than a year I am not that imressed anymore. I think netbsd needs 
cleaner upgrade procedure!

My thinking now to reinstall 2.0 from restore cd and retry the whole 
thing again. Or maybe even go back to 1.6.2 which worked very well.

Any suggestions on how to go about pkgsrc ?
I did not loose any data just time and to recover all the packages to 
previous state would take a week or so. Qube is bad platform to compile on.

How do you clean files off the machine before unpacking sets? There 
seems to be a conflict of some sort.