Subject: Re: ncurses won't build, is it just me?
To: Jamie Heilman <>
From: Kevin Lahey <>
List: port-cobalt
Date: 09/28/2001 06:33:06
In message <>Jamie Heilman writes
>Evidently its a problem with the practice of using ksh for /bin/sh.  That
>is - I moved back to bourne shell and I got it to compile, though it
>segfaulted 3 times before I finally succeeded.  Also, using ksh for /bin/sh
>does bad things to various rc scripts.  So while its an interesting kludge
>for the problem of an unstable bourne shell, its not really what I would
>call an all-encompassing workaround considering that it breaks so many
>other things in the process.  (I tried bash too and didn't have any better
>luck fwiw.)  Anyhow, when you run into this stuff, now you know one way to
>kind of get through it.

I had the same problem (libtool barfing as I tried to build TCL), and 
found that temporarily putting bash into /bin/sh fixed it.  When I tried 
to boot like that, ugly things happened, since I forgot that bash wasn't 
staticly linked.  :-(

>Has there been any progress towards getting bourne shell to more stable in

Beats me, I tried to figure out the core dumps, and even rebuilt sh with 
ElectricFence, but the core dumps still didn't make a whole lot of sense.