Subject: Re: disk translation issues, "CANNOT READ: BLK 16386"
To: None <>
From: Jamie Heilman <>
List: port-cobalt
Date: 06/27/2001 01:07:45
> > Once the kernel is switched 1.5-generic-nodma (ignore my typo above) and
> > placed on my raq1 not only do I get the same CANNOT READ: BLK 16386
> > error but when I run fdisk wd0 it panics. This is, if nothing else,

OK, real quick update... I was going to wait until I had more testing done
on this to post a summary but some stuff[1] has come up and now I'm not sure
when I'm going to have the chance to get back to it so...

You too can test the fdisk crash.  Turns out, it has nothing to do with the
raq1 hardware.  Its the 1.5_ALPHA2 generic-nodma kernel on
that causes the fdisk problem.  Actually its not that exact kernel but
rather the fact that the dma stuff is masked out (supporting evidence being
that I have 2 raq1's at work with custom 1.5 kernels which have this problem
and they both have the dma bits turned off but they are not the generic
kernel otherwise).  The crash can be duplicated on my qube2 if I use the
nodma kernel.  If I use the standard generic kernel everything works just
great (I still get the fsck core dump, I assume thats a bug in fsck_ext2fs
maybe though).

Jamie Heilman         
"...thats the metaphorical equivalent of flopping your wedding tackle 
 into a lion's mouth and flicking his lovespuds with a wet towel, pure 
 insanity..."						-Rimmer

[1] this morning my sytem disk on my firewall gave out, this evening while
I was rebuilding the disk, the machine I was using (also my netbsd bootstrapping
host) chose to completely crap itself, it now gets halfway through a fsck
and then locks solid.  Needless to say, I'm gonna have a big bonfire soon.