Port-bebox archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Successful install of a current NetBSD/bebox system

Next issue fixed:

> > > 6. mcclock(4) doesn't work correctly. The time after a cold-start is
> > > wrong (e.g. "WARNING: preposterous TOD clock time"). Maybe I
> > > need a new battery, but IIRC it worked under BeOS.

The MD bebox/isa/mcclock_isa.c requested dev/ic/mc146818.c to read and
write data in binary mode (not BCD). So we have to configure the RTC
chip into binary mode as well.

Also fixed in sandpoint/isa, which had the same problem. The RTC works now!

Other issues:

Unfortunately the multiprocessor kernel doesn't really work. Last time I
didn't notice that the second CPU hangs very soon in a high-priority xcall.
The most common case is that "makemandb" hangs on CPU1 with state "xchicv".

My first attempts to reboot the system by jumping into the boot ROM failed.
I tried the following:
1. Disable interrupts (MSR &= PSL_EE).
2. Disable the MMU (MSR &= PSL_ME | PSL_DR | PSL_IR).
3. Jump to 0xfff00100 (Boot ROM reset vector).
The system hangs directly after disabling the MMU.

Frank Wille

Home | Main Index | Thread Index | Old Index