Port-bebox archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Cannot boot from floppy disk


over the long Easter weekend I'm trying to set up my BeBox with NetBSD,
but I still have the problem that the boot floppy disks are ignored.

I tried boot.fs, boot_vga.fs and boot_com0.fs but nothing worked. After
accessing the disk drive for a short time the boot process ends in the
BeOS boot menu, where I only have the option to rescan the devices. But
nothing is found.

I learned that pressing F1 makes the BootROM to print some debugging output
to the lowest serial port (serial 4) at 19200/8N1. Indeed the BootROM
doesn't find anything usable on the disk:

Be Boot ROM, built Jun 27 1997 19:00:30
Rev 6 motherboard, Rev 5 i/o card
Copyright (C) 1991-97 Be Incorporated.  All Rights Reserved
Configured boot device is '/dev/disk/scsi/010/raw', session 0, partition 2
loading /floppy_0_0/beos/system/kernel_joe (/floppy_0_0)
load_cont(/floppy_0_0/beos/system/kernel_joe) error
loading /floppy_0_0/system/kernel_joe (/floppy_0_0)
load_cont(/floppy_0_0/system/kernel_joe) error
load_pef_kernel(): error
loading /floppy_0_0/beos/system/kernel (/floppy_0_0)
load_cont(/floppy_0_0/beos/system/kernel) error
loading /floppy_0_0/system/kernel (/floppy_0_0)
LOADER: Problem reading
load_cont(/floppy_0_0/system/kernel) error
load_pef_kernel(): error

Then I booted BeOS, although I have no experience with it, and tried to
mount the boot disk there (and finally succeeded). It shows a disk labeled
"NetBSD" in ofs format, which has the directories "system" and "Trash".
In "system" there is a file called "kernel". But it is empty! Is has 0 bytes.

Is there a known problem with the boot disks?

Frank Wille

Home | Main Index | Thread Index | Old Index