Port-bebox archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

ATA disks not recognized


neither GENERIC kernel 1.5.2, 1.5.3_ALPHA, 1.5ZC (all cross-compiled
from i386) nor the kernel from the pre-1.5.1 snapshot by Allen Briggs
from last April recognize an attached ATA disk. The symptoms are the
same for every kernel (output is from 1.5ZC on serial1):

  >> NetBSD/bebox BOOT, Revision 1.3
  >> (root%silence.homedns.org@localhost, Tue Mar 19 01:01:46 MET 2002)
  >> Memory: 98304 k

  Boot: Loading in()
  2077392+210484 [89+113696+94539]=0x261908
  [ using 208900 bytes of netbsd ELF symbol table ]
  Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002
      The NetBSD Foundation, Inc.  All rights reserved.
  Copyright (c) 1982, 1986, 1989, 1991, 1993
      The Regents of the University of California.  All rights reserved.
  NetBSD 1.5ZC (GENERIC) #2: Tue Mar 19 04:02:46 MET 2002
  total memory = 98304 KB
  avail memory = 87364 KB
  using 1254 buffers containing 5016 KB of memory
  mainbus0 (root)
  cpu0 at mainbus0: 603 (Revision 3.2), ID 0 (primary)
  cpu0: HID0 90d000<DOZE,DPM,ICE,DCE,DLOCK>
  pci0 at mainbus0 bus 0
  pci0: i/o space, memory space enabled
  pchb0 at pci0 dev 0 function 0
  pchb0: Motorola MPC105 "Eagle" Host Bridge (rev. 0x24)
  pcib0 at pci0 dev 11 function 0
  pcib0: Intel 82378ZB System I/O (SIO) (rev. 0x43)
  Symbios Logic 53c810 (SCSI mass storage, revision 0x02) at pci0 dev 12 functio
  n 0 not configured
  ex0 at pci0 dev 14 function 0: 3Com 3c905B-TX 10/100 Ethernet (rev. 0x0)
  ex0: interrupting at irq 22
  ex0: MAC address 00:10:4b:b6:e7:3b
  ex0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, default 10baseT
  pfb0 at pci0 dev 15 function 0isa0 at pcib0
  com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
  com0: console
  com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
  pckbc0 at isa0 port 0x60-0x64
  pckbd0 at pckbc0 (kbd slot)
  pckbc0: using irq 1 for kbd slot
  wskbd0 at pckbd0 mux 1
  wdc0 at isa0 port 0x1f0-0x1f7 irq 14 drq 

Then I can wait for a very long time... If I power down, detach the disk
and start again, the kernel omits the line 'wdc0 at isa0...' but I have to
wait about 40s (probably the ATA timeout) and then the kernel continues
with lpt0:
  com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
  pckbc0 at isa0 port 0x60-0x64
  pckbd0 at pckbc0 (kbd slot)
  pckbc0: using irq 1 for kbd slot
  wskbd0 at pckbd0 mux 1
  lpt0 at isa0 port 0x378-0x37b irq 7
  fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
  fd0 at fdc0 drive 1: 1.44MB, 80 cyl, 2 head, 18 sec
  biomask 40 netmask 40 ttymask c2
  raidattach: Asked for 8 units
  Kernelized RAIDframe activated
  Searching for raid components...
  boot device: <unknown>
  root on ex0
  nfs_boot: trying BOOTP

After that the system boots via NFS (1.5ZC kernel) from the i386 box.

I have tried 2 different disks (Conner 635 MB and IBM DTLA 8 GB).
BeOS can see and read from the Conner disk (haven't tried the IBM,
but I guess, no problem there, too). Changing the ATA cable didn't help.

BeBox rev6/66Mhz, ATA disks (see above), Matrox Millennium 1 with 4MB,
PCI 3Com 3c905B/TX 

Has anyone else ATA disks working on their BeBox ?

If anyone has a similar setup and a working bootdisk (console on
serial1. My tests with cons_vga showed only the Be logo and with cons_be
I could see only the first few lines of the boot loader and then a blank
screen) I would like to try it.

At the moment I am recompiling the GENERIC 1.5ZC kernel with 'options
WDCDEBUG and WDC_DIAGNOSTIC' in order to see some more diagnostic messages.


Home | Main Index | Thread Index | Old Index