Port-bebox archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: current compile

On Wed, Feb 13, 2002 at 06:26:27PM +0100, Tobias Seiler wrote:
> I tried my current compile on another box and there the serial console works.
> Now I tried to nfs mount a disk when booting the GENERIC kernel. The DHCP 
> negotiation works and I get a IP address assigned. The problem is, that I
> don't have access to the DHCP server so I can't set the directory for the
> machine.
> Then I started a bootparamd on the nfs server and used a kernel with the
> correspoding option, but it doesn't seem to try to use this server.
> Must the bootparamd be running on the same machine the dhcpd is running ?

I think I have seen something like this.  However, have you done a
tcpdump of the traffic?  Is it possible that it's trying to rarpd
before falling back to DHCP?  Can you try running rarpd/bootparamd
on the nfs server and sort of bypass the DHCP server?


 Allen Briggs                     briggs%wasabisystems.com@localhost
 http://www.wasabisystems.com/    Quality NetBSD CDs, Sales, Support, Service
NetBSD development for Alpha, ARM, M68K, MIPS, PowerPC, SuperH, XScale, etc...

Home | Main Index | Thread Index | Old Index