Port-atari archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bootloader issue

Also, in response to "Could it be so simple issue that bootloader does not find kernel ?" ..I don't think we even get to that point yet. I don't even see the banner from the second stage bootloader. I just see "Halting..."

When I ran installboot from 1.6.1 on top of the HEAD install, I could get to the second stage bootloader. But the second stage bootloader crashed, I think probably trying to load /boot.atari, the third stage, which was still the version from HEAD. I wanted to try replacing that one with the /boot.atari from a working 1.6.1 install, I just haven't had time yet.

David Ross

----- Original Message ----- From: "David Ross" <dross%pobox.com@localhost> To: "T. Makinen" <tjamaloo%gmail.com@localhost>; "Izumi Tsutsui" <tsutsui%ceres.dti.ne.jp@localhost>; "David Brownlee" <abs%netbsd.org@localhost>
Cc: <port-atari%netbsd.org@localhost>
Sent: Saturday, January 03, 2009 5:17 PM
Subject: Re: bootloader issue

That problem was the one that David's fix covered. The fix was tested to the point that we knew it unblocked the install, but we never got to the point where we could test the actual bootloader until now.

With regard to loadbsd -- what's the full command line you're using? According to docs Frank Lukas sent me, the -a option just loads to multi-user mode. I haven't tried it yet, but I assume you'll need to somehow specify that the root filesystem should be loaded from the hard drive.

The loadbsd method sounds like a good workaround, but it would be great if we can get to a point where it's possible to boot NetBSD directly off of the HD.

David Ross

----- Original Message ----- From: "T. Makinen" <tjamaloo%gmail.com@localhost> To: "Izumi Tsutsui" <tsutsui%ceres.dti.ne.jp@localhost>; "David Ross" <dross%pobox.com@localhost>
Cc: <port-atari%netbsd.org@localhost>
Sent: Saturday, January 03, 2009 4:26 PM
Subject: Re: bootloader issue

On Sat, Jan 3, 2009 at 11:57 AM, Izumi Tsutsui <tsutsui%ceres.dti.ne.jp@localhost> wrote:
David Ross wrote:

But the BOOT kernel does boot. And I successfully installed the sets via CD-ROM! The install completes successfully, but when the system is rebooted I just get "Halting..." after the memory test. This is probably from the very first stage of the netbsd bootloader but I'm not really sure. I didn't try doing a complete zero of the disk before the install -- it's conceivable
that might help.

Just FYI, I've replied to the PR:
(old firmware might not support >2GB partition on bootstrap)


I installed NetBSD 4 (base, etc and comp) installation sets without kernel (Gemdos 8+3 file name restriction messes up it's name and I'm using loadbsd.ttp
to launch NetBSD kernel from TOS). I was able to boot up system by using
loadbsd.ttp with -a flag.

I'm wondering if there's still following problem?

Could it be so simple issue that bootloader does not find kernel ?


Home | Main Index | Thread Index | Old Index