Subject: Falcon serial port problems
To: None <port-atari@NetBSD.ORG>
From: George Simunovich <>
List: port-atari
Date: 09/30/1996 19:22:09
Hello all,

I've having problems with the modem2 serial port on my Falcon running
NetBSD-1.2.  I've just installed NetBSD and installed all the binary
distribution files.  I've also grabbed the kernel source files and
compiled my own kernel using the FALCON config with FPU emulation

Every time I try to use "/dev/mdm02" I either get errors or the process

When I use "cu -l /dev/mdm02" to directly access the modem on
the port, "cu" reports "Connected." and the DTR light on the modem
lights up.  Whenever I try to type a modem command, "cu" errors out
with "cu: write: Input/Output Error" on the first keystroke. "cu" then
reports "Disconnected." and the DTR light on the modem goes out.

Every other command I've tried ("stty -a < /dev/mdm02",
"cat > /dev/mdm02") just hangs.  "ps" shows that the shell forks then
stops with "STAT" being "SV+".  I guess when the shell tries to
open "/dev/mdm02" for the redirect it gets stopped.  No job control
('^C', '^Z') works and I have to "kill" the forked shell to get my
shell back.

I'm off to try and get the Falcon's LAN port to work.  Isn't the
LAN port just a serial port, serial2?  Does it work as a normal
serial port under NetBSD?  Has anyone had any success in doing so?
I have tried to use "stty 9600 < /dev/ser02" to set it at 9600 baud,
but then "stty -a < /dev/ser02" reports a baud rate of 9562.
Trying to set it to 2400 baud then reports the baud as 2397.
What is this about?

Many thanks,


George Simunovich <>