Subject: Re: PPP
To: Christoph Simon <>
From: Leo Weppelman <>
List: port-atari
Date: 12/11/1995 22:09:43
> Hi, again
> > > 
> > [ ...... ]
> > > added a line to /etc/hosts and tried again. But alas, when I got the
> > > connected ppp0 <--> mdm02, immediately, I got a modem hang up message and
> > > half a second later, the modem disconnects. I halted the system to start
> > > it again, tried pppd without any change (well, before halting I restored the
> > > previous version of hosts), the modem didn't hang up, but also got no
> > > response from the peer: config request time out; but pppd stayed alive. 
> > > I gave no passive option. So I killed it again with -HUP, and the next try
> > > again hangs up the modem as soon as the modem handshake succeeds.
> > I have no idea what is causing the above behaviour, but I wondered if you
> > set your modem to something sane before starting a dial...
> Under MiNT I could experiment with dip or c-kermit, but currently I have
> neither compiled for NetBSD. Therefore I cann't see the modem's profiles.
> But (as always) I did it lots of times, and several times I disconnected the
> modem to switch it on again. This should be quite sane.
You can do the same with cu. Just type 'cu -l /dev/mdm02 -s <speed>'. This
should connect you to your modem.
> > > 
> > > I run the chat script with -v option, and pppd-options include debug and
> > > kdebug; but no more messages are found. Only in /etc/ppp there is a file
> > > connect-errors with length 0.
> > If I remember well, the debug will show up in /var/log/messages when you
> > add the line: '*.debug	/var/log/messages' to /etc/syslog.conf.
> I'll try this. In the meanwhile I installed mgetty because it's the only way
> I know of to receive incoming calls. The forementioned behaviour is the same,
> but this doesn't succeed to stat the lockfile (pathname is correct), 
> reports installing its own lock file (not true, that of pppd stays all the
> time) and sends stuff to the modem. I wrote a tiny program, stat is not
> broken. It must be something else. I'll ask  my mother, why this strange 
> things always happen to me ;-(
I've never compiled mgetty myself. I've got the binary from Thomas. So it
is possible to have it working correctly. Are you sure this is no permission
The line in /etc/ttys is:
	mdm02	"/usr/libexec/mgetty"	dailup on