Subject: Re: can't install NetBSD...
To: NetBSD/Atari mailing list <port-atari@NetBSD.ORG>
From: Waldi Ravens <>
List: port-atari
Date: 06/10/1995 13:52:48
Hi Benni,

> today I decided to make another try in installing NetBSD on my TT, but
> with _no_ success at all! :-(
> Ok, TT-high is working now, but I DONT get rid of these f*cking 
> MMU faults! 

A few weeks ago I started getting MMU faults too. I couldn't figure out
what's causing this (it's likely to be an initialisation problem), but
I did discover a solution: if you have MagiC2, then you should run the
NetBSD bootstrap under MagiC instead of TOS. I've been doing this for
some time now, and never seen an MMU fault since.

> The time when the kernel crashes is NOT deterministic. Sometimes right
> after loading the ramsys, sometimes while loading /bin/sh...

Hmm, on my TT the behaviour was very deterministic, the first disk write
action (e.g. write(), unlink()) would trigger MMU fault. When booting
with the autoboot option (-a), fsck would be the last thing I saw
(before the debugger, that is :-) ).

> There seems to be nothing special with my TT beside the 2 MB ST-ram.

The 2 MB ST-RAM shouldn't be a problem. I've successfully run NetBSD
in 2/4, 2/8 and 2/16 (can't test more than 16 MB TT-RAM, that's all
I've got).