Subject: Re: Chashes (Re: Problems compiling gs5.50 under NetBSD1.4.1)
To: Reinoud Zandijk <>
From: Richard Earnshaw <>
List: port-arm32
Date: 09/06/1999 13:45:49
> Hi,
> On Mon, 6 Sep 1999, Richard Earnshaw wrote:
> > Actually, I believe that the final conclusion was that there was a 
> > compiler bug, but that there were also problems with the gs source.  I 
> > managed to get a working ghostcript with the 5.87 pre-release source after 
> > the compiler had been patched, but I think you will be struggling with 
> > 5.50.  There may be newer releases than 5.87 now.
> > 
> > I've attached the compiler patch below.
> Will this mean there will be new NetBSD 1.4.1 release-binaries with the
> good compiler and everything recompiled? I'm getting almost random
> kernel-crashes lately with the NetBSD/arm32 1.4.1 kernel and userland,
> especially when compiling under load. Has something to do with pv_map and
> pointers.

I would put the probability of this compiler bug being the source of your 
problems as around 0.  The compiler bug has been there for a long time, 
and I've seen nothing in the 1.4 release that is related to it.

Can't answer on the release-binaries availability.